FANDOM


Cisco IOS configuration cheatsheet Edit

Taras Ivasyk <taras.ivasyk@gmail.com>

Version 1.0

Si vous trouvez une erreur ou voulez qu'on y ajoute quelque chose, écrivez-moi.

Configuration de base Edit

Modes de configuration Edit

Switch> enable
Switch# configure terminal
       

Effacer les fichiers de configuration sur S1 Edit

Switch# erase startup-config
Switch# delete flash:vlan.dat #<2>
Switch# reload

Configuration de base Edit

Switch(config)# no ip domain-lookup
Switch(config)# hostname S1
S1(config)# banner motd "--- Warning! Authorized access only! ---"

Sauvegard de configuration Edit

S1# copy running-config startup-config
S1# write #<3>

Sécurisation Edit

Sécurisation d'acces Edit

S1(config)# enable secret class
S1(config)# line console 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# exit
S1(config)# service password-encryption

Sécurisation de VTY par SSH Edit

S1(config)# ip domain-name cisco.com
S1(config)# crypto key generate rsa
S1(config)# ip ssh version 2
S1(config)# username <login> secret <mot-de-passe>
S1(config)# line vty 0 15
S1(config-line)# transport input ssh
S1(config-line)# login local

Sécurisation des ports Edit

S1(config)# interface range f0/1-24
S1(config-if-range)# shutdown
S1(config-if-range)# switchport port-security mac-address sticky #<2>
S1(config-if-range)# switchport port-security maximum 10
S1(config-if-range)# switchport port-security violation protect/restrict/shutdown
...
S1(config-if-range)# interface f0/1
S1(config-if)# no shutdown
...

ACL Edit

ACL standardes numérotées Edit

R1(config)# access-list <numéro> remark <texte> #<1>
R1(config)# access-list <numéro> <permit|deny> <adresse réseau> <masque générique>

ACL standards nommées Edit

R1(config)# ip access-list [standard|extended] <nom> #<1>
R1(config-std-nacl)# 10 remark <texte>
R1(config-std-nacl)# 20 permit host <adresse>
R1(config-std-nacl)# 30 deny host <adresse>
R1(config-std-nacl)# 40 <numéro> <permit|deny> <adresse réseau> <masque générique>
...
R1(config-std-nacl)# permit any

Supprimer ACL ou règles Edit

R1(config)# no access-list <numéro> #<1>
R1(config)# no ip access-list <nom>
...
R1(config)# ip access list <standard|extended> <nom>
R1(config-std-nacl)# no deny host <adresse>
R1(config-std-nacl)# no 10

Appliquer ACL sur une interface Edit

R1(config)# interface s0/0/0
R1(config-if)# ip access-group <numéro|nom> <in|out> #<1>

Interfaces Edit

Interface géstion d'un commutateur Edit

S1(config)# ip default-gateway 192.168.99.1
S1(config)# interface vlan 99
S1(config-if)# ip address 192.168.99.254 255.255.255.0
S1(config-if)# no shutdown

Routage Edit

Routage statique Edit

R1(config)# ip route 192.168.10.0 255.255.255.0 g0/1 <distance> #<1>

Route par défaut Edit

R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0 #<1>

Routage dynamique Edit

RIPv2 / IPv4 Edit

R1(config)# router rip #<1>
R1(config-router)# version 2
R1(config-router)# network <IP réseau>
...
R1(config-router)# passive-interface g0/0
...
R1(config-router)# default-information originate
R1(config-router)# no auto-summary

RIPng / IPv6 Edit

R1(config)# ipv6 unicast-routing #<1>
R1(config)# ipv6 router rip CISCO
R1(config)# interface g0/0
R1(config-if)# ipv6 rip CISCO enable

Routage sur commutateur niveau 3 (VLAN) Edit

On fait ça si on a besoin d'ajouter le routage sur un commutateur de niveau Distribution...

S1(config)# interface vlan 10
S1(config-if)# ip address 192.168.10.1
S1(config-if)# no shutdown
S1(config-if)# interface vlan 20
S1(config-if)# ip address 192.168.20.1
S1(config-if)# no shutdown
...
S1(config)# ip routing

NAT Edit

NAT statique Edit

R1(config)# ip nat inside source static <IP locale> <IP globale>
...
R1(config)# interface g0/0
R1(config-if)# ip nat inside
R1(config-if)# interface s0/0/0
R1(config-if)# ip nat outside

NAT dynamique / PAT (NAT surcharge) Edit

R1(config)# ip nat pool <nom> <IP début>  <IP fin> {netmask <masque> | prefix-length <longueur>}
R1(config)# access-list <numéro ACL> permit <IP source>
R1(config)# ip nat inside source list <numéro ACL> pool <nom> {overload}
...
R1(config)# interface g0/0
R1(config-if)# ip nat inside
R1(config-if)# interface s0/0/0
R1(config-if)# ip nat outside

VLAN Edit

Les nom des VLANs Edit

S1(config)# vlan 10 #<2>
S1(config-vlan)# name Ventes

Attribution des ports aux VLANs Edit

S1(config)# interface range f0/11-15
S1(config-if-range)# switchport mode access #<2>
S1(config-if-range)# switchport access vlan 10

Retourner un port au VLAN par défaut Edit

S1(config)# interface f0/1
S1(config-if)# no switchport access vlan #<2>

Les ports trunk sur commutateur Edit

S1(config)# interface g0/1
S1(config-if)# switchport mode trunk #<2>
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# switchport trunk allowed vlan 10,20,88,99
S1(config-if)# no shutdown

Les interfaces trunk sur routeur Edit

R1(config)# interface g0/0
R1(config-if)# shutdown
...
R1(config)# interface g0/0.10
R1(config-subif)# encapsulation dot1Q 10 #<1>
R1(config-subif)# ip address 192.168.10.1 255.255.255.0
...
R1(config)# interface g0/0.99
R1(config-subif)# encapsulation dot1Q 99 native #<1>
R1(config-subif)# ip address 192.168.99.1 255.255.255.0
...
R1(config)# interface g0/0
R1(config-if)# no shutdown

DHCP Edit

R1(config)# ip dhcp excluded-address 192.168.30.1 192.168.30.99 #<1>
R1(config)# ip dhcp pool <nom de plage>
R1(dhcp-config)# network 192.168.30.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.30.1
R1(dhcp-config)# dns-server 192.168.30.15
...
R1(config)# service dhcp

DHCP relais Edit

R2(config)# interface g0/1.10
R2(config-if)# ip helper-address 192.168.10.50 #<1>

Vérification Edit

Configuration générale Edit

S1# show running-config
S1# show version

Interfaces / ports Edit

S1# show ip interface brief
S1# show interfaces
S1# show interfaces switchport | begin fa0/10
S1# show mac address-table {interface fa0/10}

ACL Edit

R1# show interface g0/0
R1# show access-lists

Routage Edit

R1# show ip route #<1>
R1# show ip protocols

NAT Edit

R1# show ip nat translations
R1# show ip nat statistics
R1# clear ip nat statistics

VLAN / Trunk Edit

S1# show vlan {brief}
S1# show interfaces trunk
S1# show interfaces f0/1 switchport #<2>

---

Légende
#<1> = Ne s'applique qu'aux routeurs 
#<2> = Ne s'applique qu'aux commutateurs
#<3> = Commande alternative