FANDOM


Cours CCNA 3 sur Netacad

Plan du cours Edit

  1. IMG 20180410 101533
    Conception d’un réseau local
  2. Concepts et configuration de base de la commutation
  3. Évolution des Réseaux Locaux Virtuels (VLAN)
  4. Protocole VTP
  5. Protocole STP
  6. Agrégation de liaisons et redondance au premier saut
  7. Concepts et configuration de base d’un réseau sans fil
  8. Le protocole de routage EIGRP
    1. IPv4
    2. IPv6
  9. Le protocole de routage OSPF
    1. OSPF à zone unique (IPv4 et IPv6)

Conception d'un réseau local Edit

Implémentation d'une conception réseau Edit

Implémentation d'une architecture réseau Edit

La répartition de la conception en couches permet

  • mettre en œuvre des fonctions spécifiques sur chaque couche, ce qui
  • simplifie l'élaboration du réseau et, par voie de conséquence,
  • simplifie son déploiement et sa gestion.
    Screenshot 20180222 101240

Modèle de conception hiérarchique :

  • Couche d'accès
  • Couche de distribution
  • Couche cœur

Modèle de conception hiérarchique : couche d'accès Edit

  • Sécurité des ports
  • Fonctionnalité des VLAN
  • Transmission FastEthernet / GigabitEthernet
  • PoE (Power over Ethernet)
  • Agrégation de liaisons
  • Qualité de service

Modèle de conception hiérarchique : couche de distribution Edit

  • Prise en charge de la couche 3
  • Débit de transfert élevé
  • Gigabit Ethernet / 10 Gigabit Ethernet
  • Composants redondants
  • Stratégies de sécurité / listes de contrôle d'accès
  • Agrégation de liaisons
  • Qualité de service

Modèle de conception hiérarchique : couche cœur Edit

  • Prise en charge de la couche 3
  • Débit de transfert extrêmement élevé
  • Gigabit Ethernet / 10 Gigabit Ethernet
  • Composants redondants
  • Agrégation de liaisons
  • Qualité de service

Architecture d'entreprise Cisco Edit

L'architecture d'entreprise Cisco sépare le réseau en composants fonctionnels (modules), tout en préservant les couches d'accès, de distribution et cœur de réseau.

Les modules primaires :

  • Campus d'entreprise
  • Périphérie d'entreprise
  • Périphérie de Fournisseur de service (FAI)
  • À distance

Architecture d'entreprise Cisco : campus Edit

...

Domaines défaillants Edit

Un réseau bien conçu [...] réduit aussi les dimensions des domaines défaillants (de collisions et de diffusions).

Un domaine défaillant = la zone d'un réseau affectée lorsque des problèmes surviennent au niveau d'un périphérique ou d'un service réseau critique.

De plus petits domaines défaillant réduisent l'impact d'un échec sur la productivité de l'entreprise.

De plus petits domaines défaillant simplifient aussi le dépannage du réseau.

Évolution du réseau Edit

Conception pour l'évolutivité Edit

Types de commutateurs (pour les réseaux d'entreprise) Edit

  • Commutateurs LAN de campus
  • Commutateurs gérés dans le nuage (cloud)
  • Commutateurs pour Data centers
  • Commutateurs pour fournisseurs de services
  • Réseaux virtuels (Cisco Nexus)

Densité de ports Edit

Facteur de forme (form-factor)

  • Commutateurs à configuration fixe
  • Commutateurs modulaires
  • Commutateurs empilable

Débit de transfert Edit

EtherChannel [Wikipédia] ― une technologie d'agrégation de liens utilisée principalement sur les commutateurs de Cisco ; elle permet d'assembler plusieurs liens physiques Ethernet en un lien logique. Le but est d'augmenter la vitesse et la tolérance aux pannes entre les commutateurs, les routeurs et les serveurs.

  • EtherChannel utilise les ports de commutations existants (pas de frais supplémentaires).
  • Le lien EtherChannel est considéré comme un lien logique unique.
  • Configuration EtherChannel tire parti de l'équilibrage de la charge entre les liens physiques.

Power over Ethernet (PoE) Edit

Commutation multicouche Edit

Conditions de routeur Edit

Rôles de routeurs :

  • Interconnexion des sites
  • Fournir des chemins redondants
  • Interconnecter des FAI
  • Traduction entre différents types et protocoles de supports

Autres avantages de routeurs :

  • confinement des diffusions ;
  • connexion à des emplacement distants (même réseau) ;
  • regroupement logique d'utilisateurs par application ou service ;
  • sécurité améliorée.

Le routage dans les grands réseaux se base sur les protocoles de routage avancés :

  • OSPF et OSPF à zones multiples (convergence rapide);
  • EIGRP (Cisco).

Matériel de routage Edit

Catégories de routeurs Cisco :

  • Routeurs pour filiale
  • Routeurs de périphérie de réseau
  • Routeurs de fournisseurs de services

Gestion des périphériques Edit

Commandes de base de routeur en mode CLI Edit

Commandes d'affichage de base du routeur Edit

Commandes associées au routage :

show ip protocols

Affiche des informations sur les protocoles de routage configurés.

show ip route

Des informations sur les tables de routage, notamment les codes de routage, les réseaux connus, la distance administrative et les métriques.

show ip ospf neighbor

Commandes associées à l'interface :

show ip interfaces
show ip interface brief
show cdp neighbors

Évolution de VLANs Edit

VTP Edit

Le protocole VLAN (VLAN Trunking Protocol, VTP) [Wikipédia ] permet de réduire les tâches d'administration sur un réseau commuté en propageant sur les liens trunk les configurations de VLAN à travers le domaine. Propre à Cisco.

Version VTP et plage de VLAN :

  • VTP version 1 ― gère seulement la plage normale (VLAN ID 1..1005) ;
  • VTP version 2 ― gère seulement la plage normale, prend en charge Token Ring ;
  • VTP version 3 ― gère aussi la plage étendue.

Configuration VLAN est stocké dans le fichier vlan.dat.

  • Mode Serveur VTP
    • Si on configure un mot de passe VTP, il doit être le même pour tout le domaine VTP !
    • Tous les switch's sont en mode Serveur par défaut !
  • Mode Client VTP
    • Un client les informations VLAN dans la mémoire vive !
    • Ne permet pas de créer, modifier ou supprimer des VLAN manuellement !
  • Mode VTP Transparent
    • Ne participe pas à VTP (sauf pour transférer les annonces VTP aux clients VTP)
    • Les VLANs crées localement restent sur le switch en mode transparent et ne sont pas transmis.

VTP comprend 3 types d'annonces :

  1. Résumé (5 minutes) ― informent les commutateurs du nom de domaine et du numéro de révision de la configuration VTP.
  2. Requête ― envoyée en réponse à un message d'annonce type résumé avec le numéro de révision supérieur.
  3. Sous-ensemble ― contient les informations sur les VLANs.

Numéro de révision Edit

Screenshot 20180401 084500

Le numero de révision de la configuration VTP est un nombre de 32 bits inclus avec les annonces Résumé. et permet de déterminer si les données reçues sont plus récentes que la version locale.

Pour remettre à zéro :

  1. Remplacer le nom du domaine VTP par un autre nom (inexistant, par exemple) puis réattribuer le nom initial, ou...
  2. Basculer le commutateur en mode transparent puis revenir au mode VTP précédent.

Plages VLAN Edit

VLAN à plage normale (1..1005)

  • ID 1002..1005 sont réservés aux VLAN Token Ring et FDDI, il sont automatiquement créés et ne peuvent pas être supprimés.
  • Les configuration sont stockées dans vlan.dat dans la mémoire Flash (non-volatile).
  • Sont pris en charge par VTP versions 1 et 2.

VLAN à plage étendue (1006..4094)

  • Les configurations ne sont pas écrites dans vlan.dat !
  • Les configurations sont par défaut stockées dans le fichier de configuration en cours.
  • Le protocole VTP versions 1 et 2 ne prennent en charge

VTP pruning Edit

Permet d'empêcher les diffusions de se propager vers des switch's qui n'ont pas de ports Access dans le VLAN concerné par la diffusion.

On configure (active/désactive) pruning au niveau du serveur VTP.

Configuration VTP Edit

Étape 1 : Configuration su serveur VTP Edit
S1(config)# vtp mode server
Étape 2 : Configuration du nom de domaine et du mot de passe VTP Edit
S1(config)# vtp domain <nom du domaine VTP>
S1(config)# vtp password <mot de passe VTP>

Remarque ! Un switch avec le nom de domaine par défaut (NULL) acceptera le premier nom du domaine envoyé par un serveur VTP ! (à vérifier si le client doit posséder déjà le mot de passe pour le domaine).

Étape 3 : Configuration des clients VTP Edit
S2(config)# vtp mode client
S2(config)# vtp domain <nom du domaine VTP>
S2(config)# vtp password <mot de passe VTP>
Étape 4 : Configuration des VLAN sur le serveur VTP Edit
S1(config)# vlan 10
S1(config-vlan)# name SALES
S1(config-vlan)# vlan 20
S1(config-vlan)# name MARKETING
...

Remarque ! Pour supprimer un vlan ― no vlan <nom du VLAN>.

Étape 5 : Affectation de ports à des VLAN Edit
S2(config)# interface f0/10-19
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 10
...

Remarque ! La commande switchport access vlan <ID> force la créaton du VLAN <ID> s'il n'existe pas déjà.

Vérification VTP et VLAN Edit

Switch# show vtp status
Switch# show vtp password
...
Switch# show vlan brief

DTP Edit

Le protocole DTP (Dynamic Trunking Protocol) [Wikipédia] gère la négociation du trunk si le port du commutateur voisin est configuré dans un mode trunk et prend en charge le DTP, lui aussi.

Switchport modes :

  • Access : le port n'est pas en mode trunk
  • Dynamic auto : (par défaut) l'interface convers la liaison en trunk ou accès si l'interface voisine est en mode trunk ou désirable.
  • Dynamic desirable : l'interface tente activement de convertir la liaison en liaison trunk, si l'interface voisine est en mode trunk, desirable ou dynamique.
  • No-negotiate : désactiver le protocole DTP sur le port ; le mode opérationnel (access ou trunk) doit être configuré manuellement.

Configuration DTP Edit

...

Vérification DTP Edit

Switch# show dtp interface f0/1
Switch# show interfaces f0/1 switchport

Exercice Edit

  • PKT 2.1.4.4 et
  • Lab 2.1.4.5.

Résolution des problèmes multi-VLAN Edit

...

Commutation de couche 3 Edit

Commutateur multicouche :

  • Port routé : interface de couche 3 pure (similaire à une interface physique sur un routeur) ;
  • Interface virtuelle de commutateur (SVI) : interface VLAN virtuelle pou rle routage inter-VLAN.

Commutateurs Cisco multicouches :

  • Catalyst 6500 utilise Cisco Express Forwarding (CEF) [Wikipédia] pour le routage et des interfaces de couche 3 par défaut ;
  • Catalyst 4500 ― CEF et des interfaces de couche 2 par défaut ;
  • Catalyst 3560 ― routage statique (à vérifier) et des interfaces de couche 2 par défaut ;
  • Catalyst 2960 (IOS 12.2(55) ou plus) ― routage statique et des interface de couche 2 par défaut ; pas de ports routés.

Routage inter-VLAN au moyen d'interfaces virtuelles (SVI) Edit

Screenshot 20180402 094910 lomo

Par défaut, une interface SVI est créée pour le VLAN par défaut (VLAN 1). Des interfaces SVI supplémentaires doivent être explicitement créées : elles sont créées la première fois que le mode de configuration d'interface VLAN est saisi (exemple : interface vlan 10).

Les raisons de configurer SVI :

  • Fournir une passerelle pour un VLAN ;
  • Assurer la connectivité IP de couche 3 au commutateur ;
  • Prendre en charge le protocole de routage et les configurations de pontage

Les avantages des interfaces SVI :

  • Plus rapide que le modèle Router-on-a-stick ;
  • Pas nécessaire d'utiliser des liaisons externes entre le commutateur et le routeur pour le routage ;
  • Ne se limite pas à une seule liaison physique : des liaisons EtherChannels de couche 2 utilisées.
Configuration d'interface SVI Edit
Switch(config)# vlan 10
Switch(config-vlan)# name SALES
Switch(config)# interface vlan 10
Switch(config-if)# ip address 192.168.10.1 255.255.255.0
...
Switch(config)# ip routing
...

Routage inter-VLAN au moyen de ports routés Edit

Un port routé est un port physique qui fait office d'interface sur un routeur :

  • un port routé n'est pas associé à un VLAN spécifique ;
  • un port routé se comporte comme une interface de routeur normale ;
  • les protocoles de couche 2 (STP, etc.) ne fonctionnent pas sur une interface routée ;
  • certaines protocoles (LACP et EtherChannel par exemple) fonctionnent au niveau de la couche 3.

Remarque ! Contrairement aux routeurs Cisco, les ports routés sur un commutateur Cisco ne prennent pas en charge les sous-interfaces.

Configuration d'un port routé Edit
Switch(config)# interface g0/1
Switch(config-if)# no switchport
...
Switch(config)# ip routing

Problèmes de configuration de routage inter-VLAN sur des commutateurs de la couche 3 Edit

  • VLAN
    • les VLAN doivent être définis sur tous les commutateurs ;
    • les VLAN doivent être activés sur les ports trunk ;
    • les ports doivent se trouver dans les VLAN appropriés.
  • SVI
    • les SVI doivent disposer de l'adresse IP et du masque de sous-réseau correct ;
    • chaque interface SVI doit correspondre au numéro du VLAN ;
    • les SVI doivent être opérationnelles.
  • Routage
    • le routage doit être activé ;
    • chaque interface ou réseau doit être ajouté au protocole de routage (ou des routes statiques doivent être saisies).
  • Hôtes
    • les hôtes doivent avoir l'adresse IP et le masque de sous-réseau correct ;
    • les hôtes doivent avoir une passerelle par défaut (associée à une interface SVI ou un port routé).

Redondance LAN, protocole STP Edit

Introduction : problèmes de redondance LAN Edit

Conséquences de la redondance au niveau de couche 2

  • Instabilité des tables MAC
  • Les tempêtes de diffusion
  • Plusieurs copies de la même trame

Concepts du protocole STP Edit

Spanning Tree Protocol (STP) [Wikipédia] = ...

STP garantit l'unicité du chemin logique entre toutes les destinations sur le réseau en bloquant (pas shutdown !) les ports redondants.

Un port bloqué ― des données d'utilisateur ne sont pas autorisées à circuler par le port ; ceci n'inclut pas les trames BDPU.

Bridge Protocole Data Unit (BPDU) [Wikipédia] = ...

La sélection se fait par le plus petit :

  • Root ID : Priority > address MAC
  • Bridge ID : Priority > address MAC

Port racine ― le port de commutation le plus proches du pont racine (root bridge).

Ports désignés (forward port) ― tous les ports qui sont autorisés à acheminer le trafic. Tous les ports du pont racine (root bridge) sont désignés.

États des ports Edit

Opérations autorisées État du port
Blockage Écoute Apprentissage Transfert Désactivé
Recevoir et traiter des trames BPDU + + + +
Réacheminer des trames de données +
Réacheminer des trames de données commutées provenant d'une autre interface +
Apprendre des adresse MAC + +

Configuration de STP sur un port Edit

S1(config)# spanning-tree mode ...

Pour les ports d'accès

S1(config-if)# spanning-tree portfast
S1(config-if)# spanning-tree bpduguard enable

Vérification

S1# show spanning-tree

VLAN Edit

Pour chaque VLAN on peut configurer STP priorité.

S3(config)# spanning-tree vlan 1 priority 4096

Répartition de charge et redondance avec VLAN

Méthode 1 :

S1(config)# spanning-tree VLAN 1 root primary
S2(config)# spanning-tree VLAN 1 root secondary

Méthode 2 :

S3(config)# spanning-tree VLAN 1 priority 24576

Variétés de protocoles STP Edit

PVST+ (Cisco) ... Edit

Rapide PVST (RSTP) ... Edit

...

Configuration du protocole STP Edit

Protocole de redondance au premier saut Edit

...

Agrégation de liaisons et redondance au premier saut Edit

EtherChannel Edit

EtherChannel [Wikipédia] ― une technologie d'agrégation de liens utilisée principalement sur les commutateurs de Cisco ; elle permet d'assembler plusieurs liens physiques Ethernet en un lien logique. Le but est d'augmenter la vitesse et la tolérance aux pannes entre les commutateurs, les routeurs et les serveurs.

  • EtherChannel utilise les ports de commutations existants (pas de frais supplémentaires).
  • Le lien EtherChannel est considéré comme un lien logique unique.
  • Configuration EtherChannel tire parti de l'équilibrage de la charge entre les liens physiques.

Autres caractéristiques

  • Le protocole peut regrouper jusqu'à 16 ports Ethernet.
  • Les commutateur Cisco IOS peuvent prendre en charge 6 EtherChannel's.
  • Des liens EtherChannel peuvent être formés par négociation (PAgP ou LACP)

PAgP Edit

PAgP (Port Agregation Protocol) [Wikipédia] ― ...

Modes PAgP

  • Active ― en mode agrégation sans négociation
  • Desirable ― demande activement de basculer vers agrégation
  • Auto ― attend passivement l'invitation de basculer vers agregation.

LACP Edit

LACP [Wikipédia] ―

Configuration EtherChannel Edit

Screenshot 20180223 090459

Pre-requisits

  • Prise en charge d'EtherChannel sur tous les modules
  • Vitesse et mode duplex
  • VLAN doit être compatible (tous les interfaces sont sur le même VLAN)
  • Plage VLAN permise sur le trunk

Mode On (sans protocole)

...

S1(config)# interface range FastEthernet 0/1-2
S1(config-if-range)# channel-group 1 mode on

Il faut répéter la même configuration sur les ports correspondants de l'autre commutateur, bien sûr.

Mode Desirable

Protocoles de redondance au premier saut Edit

Protocole HSRP Edit

Configuration de HSRP

Étape 1 : créer les SVI au niveau de chaque switch

S1(config)# interface vlan 10
S1(config-if)# ip address 10.0.10.2 255.255.255.0

Étape 2 : choisir une IP virtuelle et spécifier une priorité (défaut 100)

S1(config-if)# standby 1 ip 10.0.10.1
S1(config-if)# standby 1 priority 150

Étape 3 : Preempt oblige le switch niveau 3 de prendre en charge la priorité

S2(config-if)# standby 1 ip 10.0.10.1
S2(config-if)# standby 1 preempt

Protocole GLBP Edit

Ajoute la fonction de load balancing.

R1(config)# interface f0/0
R1(config-if)# no shutdown
R1(config-if)# interface f0/0.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip address 10.0.10.2 255.255.255.0
R1(config-subif)# glbp 1 ip 10.0.10.1
R1(config-subif)# glbp 1 priority 150
R1(config-subif)# glbp 1 preempt
R1(config-subif)# glbp 1 load-balancing round-robin

NoteEdit

Load balancing : protocole GLBR. Mais on peut faire aussi répartition de charge manuellement (HSRP + STP).

Réseaux sans fil Edit

Avantages du sans fil

...

Types de réseaux sans fil

  • Réseaux personnels sans fil (WPAN)
  • Réseaux locaux sans fil (WLAN)
  • Réseaux
  • Réseaux WiMAX
  • Haut débit cellulaire
  • Haut débit satellite

Matériel sans fil Edit

...

Fonctionnement sans fil Edit

Authentification Edit

...

Menaces WLAN Edit

Les attaques DoS Edit

...

Attaques DoS de trames de gestion

...

Points d'accès non autorisés Edit

...

Attaques de l'intercepteur Edit

...

Sécurisation de la technologie sans fil

...

Configuration du point d'accès Edit

Protocoles de routage dynamique Edit

Screenshot 20180305 084317 lomo

Le fonctions des protocoles de routage dynamique :

  • Découverte des réseaux distants
  • Actualisation des informations de routage
  • Choix du meilleur chemin
  • Capacité à trouver un nouveau meilleur chemin si le chemin actuel n'est plus disponible.

Classification de protocoles de routage Edit

Protocoles de routage IGP et EGP Edit

Interior Gateway Protocols (IGP) [Wikipédia] ― ...

Exterior Gateway Protocols (EGP) [Wikipédia] ― ...

Screenshot 20180305 090047 lomo

Protocoles à vecteur à distance Edit

Distance identifie la distance par rapport au réseau de destination...

Vecteur indique la direction de l'interface...

Un routeur utilisant un protocole de routage à vecteur de distance ne connaît pas le chemin complet vers un réseau de destination, il connaît juste sa distance.

Protocoles à état de lien Edit

Les protocoles IGP à état de lien sont :

  • OSPF ― Protocole standard utilisé dans les LAN
  • IS-IS ― Protocole utilisé sur les réseaux internes des fournisseurs (FAI)

Protocoles de routage par classe

  • Protocoles de routage sans classe ― incluent les informations de masque de sous-réseau ndas les mises à jour de routage.
  • Protocoles de routage par classe ― ne supportent pas les masques VLSM et créent des problèmes sur les réseaux discontinus.

Le fonctionnement des protocoles de routage dynamique Edit

Métriques de protocoles de routage Edit

  • RIP : nombre de sauts
  • OSPF :bande passante cumulée entre deux points

Algorithme Edit

  1. Démarrage à froid
  2. Découverte de réseau (Network discovery)
  3. Échange des informations de routage

Le protocole de routage EIGRP Edit

CCNA3, Chapitre 6

Caractéristiques de EIGRP Edit

Les concepts EIGRP abordés :

  • Récapitulation de route automatique ;
  • Équilibrage de charge ;
  • Routes par défaut ;
  • Minuteurs de mise hors service ;
  • Authentification.

Configuration de EIGRP pour IPv4 Edit

R1(config)# router eigrp <autonomous system>
R1(config-router)# eigrp router <ipv4-address>
R1(config-router)# network <address> <generic mask>
R1(config-router)# passive-interface <interface>
R1(config-router)# redistribute static|rip|ospf|connected
Récapitulation de route Edit

La récapitulation de route permet de regrouper des réseaux et de les annoncer comme un seul grand groupe à l'aide d'une route récapitulée unique.

Avantages :

  • réduire le nombre d'entrées dans les mises à jour de routage ;
  • réduire la consommation de bande passante par les mises à jour de routage.
  • réduire la taille des tables de routage locales.

Inconvénients :

  • Screenshot 20180402 162003 lomo
    peut générer des boucles de routage !

Le protocole EIGRP pour IPv4 utilise une route Null0 pour empêcher les boucles. EIGRP intègre automatiquement une route récapitulative Null0 si :

  • la récapitulation automatique est activée ;
  • il existe au moins un sous-réseau qui a été acquis via EIGRP ;
  • il existe plusieurs commandes network dans la configuration.
Configuration de récapitulation de route automatique Edit
Switch#(config)# router eigrp <as-number>
Switch#(config-router)# auto-summary
Configuration de récapitulation de route manuelle Edit
R3(config) interface s0/0/0 
R3(connfig-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0
Vérification Edit
Switch# show ip protocols
Switch# show ip route eigrp
Switch# show ip eigrp topology all-links
Propagation d'une route statique par défaut Edit
Screenshot 20180402 171404 lomo

La commande redistribute static du protocole EIGRP inclue les routes statiques dans les mises à jour EIGRP.

Bande passante pour EIGRP Edit

Par défaut EIGRP n'utilise que 50 % max de la bande passante d'une interface. Pour changer :

Switch(config)# interface s0/0/1
Switch(config-if)# ip bandwidth-percent eigrp <as-number> <x%>

La commande pour IPv6 est la même, sauf ipv6 au lieu de ip.

Minuteurs Hello et mise en attente Edit

  • Intervalle Hello ― temps avant l'envoi d'un paquet « Hello » du protocole Hello léger.
  • Le temps d'attente ― le temps maximal à attendre avant de déclarer que son voisin est inaccessible.
Switch(config)# interface s0/0/1
Switch(config-if)# ip hello-interfal eigrp <as-number> <seconds>
Switch(config-if)# ip hold-time eigrp <as-number> <seconds>

Les commandes pour IPv6 sont les mêmes, sauf ipv6 au lieu de ip.

Équilibrage de la charge IPv4 à coût égale Edit

Par défaut ― jusqu'à 4 routes dans la table de routage.

Switch(config-router)# maximum-paths <nombre de routes>

Remarque ! EIGRP utilise uniquement la bande passante la plus lente dans sa métrique composite.

Équilibrage de la charge IPv4 à coût inégale Edit

La commande variance permet à EIGRP d'installer plusieurs routes sans boucle avec un coût inégal pour faire l'équilibrage :

  • variance = 1 : seules les routes avec la même métrique sont permises pour l'équilibrage ;
  • variance = 2 : toute route apprise par EIGRP avec une métrique inférieure à 2 fois la métrique du successeur sera utilisé pour l'équilibrage.

Pour repartager la distribution du traffic entre differentes routes avec le coût inégal ― la commande traffic-share balanced.

Exemple :

Switch(config-router)# variance 2
Switch(config-router)# traffic-share balanced

Vérification Edit

Screenshot 20180312 085413
show ip route
show ip protocols
show ip eigrp neighbors
show ip eigrp topology
show ip eigrp interfaces

Fonctionnement de EIGRP Edit

3 tables Edit
  • table de routage
  • table de voisinage
  • table de topologie
La métrique EIGRP Edit
  • bande passante
  • délai

m = 256*[107/min(bandwidth) + Sum(delais/10)]

ID de routeur EIGRP/OSPF Edit

ID EIGRP = une adresse IPv4

Configuration de EIGRP pour IPv6 Edit

Il faut configurer l'ID du routeur.

L'adresse link-local est la même pour chaque interface d'un routeur.

R1(config)# ipv6 unicast-routing
R1(config)# ipv6 router eigrp 2
R1(config-rtr)# no shutdown
R1(config-rtr)# eigrp router-id 1.1.1.1
...
R1(config)# interface g0/0
R1(config-if)# ipv6 eigrp 2
...

Vérification

R1# show ipv6 protocols

Sécurité EIGRP Edit

Authentification avec MD5

Étape 1 : créer une chaîne de clés

Router(config)# key chain <name-of-chain>
Router(config-keychain)# key <key-id>
Router(config-keychain-key)# key-string <key-password>

Étape 2 : configurer authentification à l'aide de la chaîne de clés

Router(config)# interface s0/0/0
Router(config-if)# ip authentication mode eigrp 100 md5
Router(config-if)# ip authentication ...

OSPF à zone unique Edit

Le protocole OSPF (Open Shortest Path First) [Wikipédia] ― un protocole de routage interne IP de type « à état de liens » (OSPFv2 RFC 2328, OSPFv3 RFC 2740).

Caractéristiques OSPF Edit

  • Sans classe : OSPFv2 est sans classe par conception.
  • Efficace : mises à jour seulement pour des changements de routage ; algorithme SPF pour le meilleur chemin.
  • Convergence rapide : diffuse rapidement les modifications (la distance administrative OSPF = 110).
  • Évolutif : fonctionne bien sur les petits et grands réseaux.
  • Sécurisé :
    • OSPFv2 utilise MD5 / SHA
    • OSPFv3 utilise IPSec

Composants du protocole OSPF

  • 3 tables de données (par le système d'adressage)
    • table de voisinage (show ip ospf neighbor)
    • table topologique (show ip ospf database)
    • table de routage (show ip route)

Fonctionnement OSPF

  1. Établir les contiguïtés de voisinage (paquets « Hello »)
  2. Échanger des informations sur l'état et le coût de chaque lien (paquets LSA)
  3. Établir la table topologique
  4. L'algorithme SPF

Zone unique vs zones multiples

  • OSPF à zone unique : tous les routeurs sont situés dans une zone fédératrice (area 0)
  • OSPF multizone : plusieurs zones, de façon hiérarchique ; toutes les zones doivent se connecter à la zone fédératrice ; les routeur reliant les zones entre elles sont des routeurs ABR (Area Border Router).

OSPF à zones multiples Edit

CCNA 3 (version 6), chapitre 9

Screenshot 20180409 082957

Protocoles de routage à état de lien Edit

Fonctions :

  • réaction rapide aux changements dans la topologie du réseau ;
  • mises à jour suit à un changement de la topologie ;
  • mises à jour périodiques (rafraîchissements d'état de liens) ;
  • mécanisme HELLO pour déterminer l'accessibilité de voisins ;
  • informations HELLO et mises à jour de routage reçus des autres routeurs ― base de données sur le réseau ;
  • algorithme du plus court chemin d'abord (SPF) pour calculer les routes.

Le routage à l'état de liens utilise :

  • des mises à jour de routage à état de liens (LSA) ;
  • une base de données topologiques ;
  • l'algorithme de plus court chemin d'abord (SPF) ;
  • l'arbre SPF résultant ;
  • une table de routage contient les meilleurs chemins.

Types de paquets utilisés :

  • Hello
    • chaque routeur surveille l'état de ses voisins directement connectés ;
    • le paquet Hello contient des informations sur les réseaux reliés au routeur.
  • LSA
    • chaque routeur surveille aussi tous les routeurs de son réseau ou de sa zone au moyen de mises à jour de routage à état de liens (LSA) ;
    • les paquets LSA fournissent des mises à jour sur l'état des liens (interfaces) sur tous les routeurs du réseau.

Terminologie :

  • Liaison (Link) : interface sur un routeur
  • État de lien (Link state) : état d'une liaison entre deux routeur (à préciser !)
  • Zone (Area) : ensemble des réseaux et des routeurs ayant la même identification de zone et la même base de données de liens.
  • Coût (Cost) : valeur affectée à une liaison (à préciser !)
  • Table de topologie (Topological database) : liste d'informations relatives aux autres routeurs de l’inter-réseau
  • Table de routage (Routing table) : obtenue à partir de la table topologique en exécutant l'algorithme SPF ; la table de routage de chaque routeur du même réseau est unique
  • Base de voisinage (Adjacency database) : chaque routeur conserve une liste de voisins (à préciser !)

Pourquoi utiliser OSPF à zones multiples Edit

Le protocole OSPF à zone unique est utile sur les réseaux de petite taille où la structure des liaisons du routeur n'est pas complexe et où les chemins d'accès aux différentes destinations peuvent être déterminés facilement.

Le protocole OSPF gére 3 tables :

  • table de voisinages ;
  • table de topologie ;
  • table de routage (obtenue depuis la table de topologie à l'aide d'algorithme SPF.

Inconvénients du protocole OSPF à zone unique Edit

  • Screenshot 20180409 111559
    taille excessive de la table de routage de réseau de grande taille ― pas de récapitulation ou résumé de route par défaut) ;
  • taille excessive de la base de données d'états de liens (LSDB)
  • fréquence élevée des calculs de l'algorithme SPF
Screenshot 20180409 113623

Le protocole OSPF à zones multiples est utilisé pour diviser en plusieurs zones un réseau OSPF de grande taille. Ça nécessite une conception de réseau hiérarchique : la zone principale est appelée zone fédératrice (zone 0), toutes les autres zones doivent y être reliées.

Zone fédératrice (transit), ou zone 0

  • la zone dont la principale fonction est de faire circuler de manière rapide et efficace les paquets IP ;
  • connectée à d'autres types de zone OSPF.

Zone normale (non-fédératrice)

  • met en relation les utilisateurs et les ressources ;
  • une zone normale n'autorise pas le trafic issu d'une autre zone à utiliser ses liens pour parvenir à d'autres zones (il faut plutôt passer par la zone 0).

Fonctionnement du protocole OSPF à zones multiples Edit

Types de routeur OSPF Edit

  • Routeur interne : un routeur dont toutes les interfaces se situent dans la même zone ; les lsdb de tous les routeurs internes à une zone sont identiques.
  • Screenshot 20180409 114900
    Routeur fédérateur : un routeur situé dans la zone fédératrice (c'est à dire au moins une interface du routeur appartient à la zone 0).
  • Screenshot 20180409 114922
    Routeur de la bordure de zone (Area Border Router, ABR) : un routeur possédant des interfaces dans différentes zones ; il doit gérer des LSDB distinctes pour chaque zone à laquelle il est connecté et être capable de router entre les zones ; les informations de routage destinées à une autre zone ne peuvent y parvenir que par l'intermédiaire de l'ABR de la zone locale ; les ABR distribuent des informations de routage à la zone fédératrice.
  • Screenshot 20180409 114941
    Routeur de la bordure de système autonome (Autonomous System Boundary Router, ASBR) : un routeur possédant au moins une interface vers un inter-réseau externe (autre système autonome), par exemple un réseau non-OSPF ; un ASBR peut importer des informations relatives au réseau non-OSPF dans le réseau OSPF et inversement (redistribution des router).

Types de LSA Edit

Type de LSA Description
1 LSA de routeur
2 LSA de réseau
3 et 4 LSA de récapitulation
5 LSA externe du système autonome
6 LSA OSPF de multidiffusion
7 Défini pour les NSSA
8 LSA d'attributs externes pour le protocole BGP
9, 10 et 11 LSA opaques
Screenshot 20180409 120410
LSA OSPF type 1 : LSA de routeur Edit
  • contiennent une liste des types de lien et des préfixes de réseau connectés directement ;
  • tous les routeurs émettent des LSA type 1 ;
  • sont diffusées au sein de la zone et ne se propagent pas au-delà du routeur ABR ;
  • l'ID d'état de lien d'une LSA type 1 est identifié par l'ID de routeur d'origine.
Screenshot 20180409 120922
LSA OSPF type 2 : LSA du réseau Edit
  • identifient les routeurs et les adresses réseau des liens à accès multiple ;
  • seul un DR émet des LSA type 2 ;
  • sont diffusées au sein du réseau à accès multiple et ne se propagent pas au-delà du routeur ABR ;
  • l'ID d'état de lien d'une LSA type 2 est identifié par l'ID de routeur désigné (DR)
Screenshot 20180409 121328
LSA OSPF type 3 : LSA de récapitulation Edit
  • décrit l'adresse réseau apprise par les LSA de type 1 ;
  • est requise pour chaque sous-réseau ;
  • les routeurs ABR diffusent les LSA type 3 dans d'autres zones, où elles sont régénérées par d'autres ABR ;
  • l'ID d'état de lien d'une LSA type 3 est identifié par l'adresse réseau ;
  • par défaut, les routes ne sont pas récapitulées.

Réglage et dépannage du protocole OSPF Edit

OSPF sur les réseaux à accès multiple Edit

Screenshot 20180416 084918

Les types de réseau OSPF

...

Challenges du protocole OSPF

  • Screenshot 20180416 085925
    Création de contiguïtés multiples
  • Diffusion massive de paquets LSA

...

Le routeur désigné (DR) du protocole OSPF

Screenshot 20180416 085808

...

Vérifier les rôles de routeur désigné (DR) et du routeur désigné de secours (BDR)

OSPFv2 :

show ip ospf interface

OSPFv3 (IPv6) :

show ipv6 ospf interface

Vérifier les contiguïtés du routeur désigné (DR) et du routeur désigné de secours (BDR)

OSPFv2 :

show ip ospf neighbor

Le processus de sélection du DR/BDR par défaut

...

La valeur de la priorité

Au niveau de l'interface connectée à un commutateur :

ip ospf priority <value>

Si <valeur> = 0, le routeur ne peut pas être ni DR, ni BDR !

Propagation d'une route par défaut Edit

Propager une route statique par défaut dans OSPFv2

ip route 0.0.0.0 0.0.0.0 <ipaddress | exit-interface>
default-information originate

Vérifier la route IPv4 par défaut propagé

show ip route

Bien sûr, ça se fait sur les autres routeurs voisins.

Ajustement des interfaces OSPF Edit

Les intervalles Hello et Dead OSPF

  • Configurables par interface
  • Si les intervalles OSPF ne correspondent pas sur les interfaces de routeurs voisins, la contiguïté de voisinage ne peut pas s'établir.

Modifier les intervalles OsPFv2 (très déconseillé...)

...