FANDOM


Précédent : 2017-11-27 / 420-R63-MA / Infrastructure réseau 2

NAT Edit

Addresses réseau privées Edit

Non-routable en dehors du réseau local !

  • 192.168.x.x /24
  • 172.16.x.x /12
  • 10.x.x.x /8

Translation statique / dynamique / surcharge Edit

NAT statique Edit

Mappage de type un à un des adresses locales et globales :

  • IPprivé <―> IPstatique

NAT dynamique Edit

Utilise un pool d'adresses publiques et les attribue selon la méthode du premier arrivé, premier servi :

  • IPprivé <―> IPdynamique

Surcharge (overload) Edit

Nommé aussi Port Address Translation (PAT) ― mappe plusieurs adresses IPv4 privées à une seule adresse IPv4 publique ou à plusieurs adresses en utilisant les numéros de port pour transmettre les paquets de réponses au bon appareil interne.

Avantages / inconvénients de NAT Edit

Avantages Edit

  • ...

Inconvénients Edit

  • ...

Configuration de NAT Edit

NAT statique Edit

  • ip nat inside
  • ip nat outside

Créer le mappage entre les adresses locales internes et les adresses locales externes :

R1(config)# ip nat inside source static <IP locale> <IP globale>

Exemple :

R1(config)# ip nat inside source static 192.168.12.10 209.165.20.15

Définir quelles interfaces appartiennent au réseau interne et lesquelles ― au réseau externe :

R1(config)# interface g0/0
R1(config-if)# ip nat inside 
...
R1(config)# interface s0/0/0
R1(config-if)# ip nat outside <interface>

Vérifier la NAT statique :

R1# show ip nat translations
R1# show ip nat statistics
R1# clear ip nat statistics

NAT dynamique Edit

Créer le mappsge entre les adresses locales internes et les adresses locales externes :

R1(config)# ip nat pool <nom de  plage> <IP début> <IP fin> { netmask <masque> | prefix-length <longueur> }

Exemple :

R1(config)# ip nat pool POOLLAN1 64.50.12.1 64.50.12.2 netmask 255.255.255.252

Créer une liste de contrôle d'accès standard pour permettre la traduction de ces adresses :

R1(config)# access-list <numéro ACL> permit <IP source>

Exemple :

R1(config)# access-list 10 permit 192.168.12.0

Relier la liste de contrôle d'accès au pool :

R1(config)# ip nat inside source list <numéro ACL> pool <nom de plage>

Identifiez les interfaces internes et externes :

R1(config)# interface g0/0
R1(config-if)# ip nat inside 
...
R1(config)# interface s0/0/0
R1(config-if)# ip nat outside <interface>

NAT surcharge Edit

Il faut juste modifier une commande de l'étape précédent :

R1(config)# ip nat inside source list <numéro ACL> pool <nom de plage> overload