FANDOM


Précédent : 2017-11-23 / 420-R63-MA / Infrastructure réseau 2

DHCP Edit

Service DHCP sur un serveur Edit

S'il y a un serveur DHCP, etc., on peut acheminer les requets UDP broadcast (DHCP, etc.) vers le serveur par un interface/addresse sur l'interface du réseau de poste qui a besoin d'accès à DHCP :

R2(config-if)# ip helper-address 192.168.10.50 

Sinon, les requets DHCP (diffusion !) ne sont pas acheminés par le routeur entre différents LAN/VLAN.

Donc, deux cas :

  1. Serveur DHCP sur le même réseau ? Le routeur n'intervient pas dans le DHCP.
  2. Serveur DHCP sur un autre réseau (VLAN) ?
    • Routeur comme relais DHCP
    • ip helper-address <IP serveur> (sur l'interface du réseau des hôtes)

Service DHCP IPv4 sur un routeur Edit

Étape 1 : Exclure un plage Edit

Première chose à faire : exclure la plage des adresses que routeur ne peut pas attribuer aux hôstes :

R1(config)# ip dhcp excluded-address  192.168.30.1 192.168.30.99

On peut aussi exclure une adresse (seulement il faut donner une seule adresse ici).

Étape 2 : Définir un plage d'adresses (pool) Edit

R1(config)# ip dhcp pool <nom de plage>
R1(dhcp-config)# network 192.168.30.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.30.1
R1(dhcp-config)# dns-server 192.168.30.15

Service DHCP IPv6 sur un routeur Edit

R1(config)# ipv6 unicast-routing
R1(config)# ipv6 dhcp pool <nom de plage>
R1(config-dhcpv6)# dns-server <IPv6>
R1(config-dhcpv6)# domain-name example.com
R1(config-dhcpv6)# exit
R1(config)# interface g0.1/20
R1(config-subif)# ipv6 address <IPv6>/64
R1(config-subif)# ipv6 dhcp server <nom de plage>
R1(config-subif)# ipv6 ...

ACL (rappel) Edit

Exercice :

  • juste PC.10 peut ouvrir une session telnet sur le routeur ;
  • le réseau VLAN20 peut ouvrir une session sur le routeur.
  • le réseau VLAN30 ne peut pas pinguer le VLAN10
ip access-list standard TELNET_VTY
10 permit host 192.168.10.10
20 permit 192.168.20.0 0.0.0.255
30 deny any
exit
line vty 0 15
ip access-class TELNET_VTY in

et

ip access-list 1 deny 192.168.30.0 0.0.0.255
ip access-list 1 permit any
interface g0/1.10
ip access-group 1 out